iPlug2 Forum

Consistent Error on Building After Opening Plugin in DAW

I’m experiencing an issue right now where the project will not compile unless I completely close out my DAW (FL Studio) each time. I get the error equivalent of just leaving it loaded in the DAW and trying to build the project again. Here’s the error thrown:

If I close out my DAW and attempt to build, everything works - this is very tedious after a while of needing to open up and close my DAW every time I build to test. I have a hunch that it is a memory issue, but I haven’t been able to find anything that would trip it up. Are there any suggestions to fixing this?

I resolved it self, using this line in the post build events worked for some reason:
xcopy /d /y "C:\data\iPlug2\Examples\Saxon\third_party\fftw\bin\libfftw3f-3.dll" "$(TargetDir)"
Have absolutely no clue why that worked. I’m using FFTW as a static library, so I have no clue why copying a .dll would fix it. The plugin worked without the line, so I’m completely baffled.

The DLL is locked by windows so the post build copy script doesn’t work.

FWIW it’s pretty normal to have to restart your DAW each time you recompile. In some cases with DAWs that bridge plug-ins you don’t have to.