iPlug2 Forum

VS 2019 Update 16.11 (10-Aug-2021) Breaks Build With IGRAPHICS_SKIA

Anybody else sees this problem, too?

The lastest Visual Studio 2019 update 16.11. from 10-Aug-2021 breaks any iPlug2 build using IGRAPHICS_SKIA with the following compiler error:

Compiler Error C2027: use of undefined type ‘SkSVGNode’

However, the include path to the respective .h is definitely visible and available.
Compiling with the previous update 16.10 or in VS 2017 (latest update) works fine…

Is this still a problem? I’m about to update Visual Studio.

For me: yes. They brought a mini update (16.11.1) later but that did not fix my issue.
It might be on my side only, but since I have no time to investigate I reverted to VS 2017 for the time being.

Thanks for your fast reply.
I will update and let you know whether it worked.

1 Like

OK, same problem here after updating VS 2019 to 16.11.1.
Here’s how to get back to an earlier VS 2019 version (Professional and Enterprise editions only): Visual Studio 2019 build numbers and release dates | Microsoft Docs

Yes, works fine. I used the VC Enterprise installer of the desired version (16.10.4 in my case), and I was able to install the respective Community version of VS (option “full download, then install”). :+1:

The latest VS 2019 version 16.11.2 has got the same problem.

Oh my, so I’ll stay with 16.10.4 then. Thanks Kay! :+1:

1 Like

Just modify this file “Dependencies\Build\src\skia\modules\svg\include\SkSVGDOM.h”

It has to include “modules/svg/include/SkSVGDefs.h” and then it builds fine again in 16.11.*


/*

  • Copyright 2016 Google Inc.
  • Use of this source code is governed by a BSD-style license that can be
  • found in the LICENSE file.
    */

#ifndef SkSVGDOM_DEFINED
#define SkSVGDOM_DEFINED

#include “include/core/SkFontMgr.h”
#include “include/core/SkRefCnt.h”
#include “include/core/SkSize.h”
#include “include/private/SkTemplates.h”
#include “modules/svg/include/SkSVGIDMapper.h”
#include "modules/svg/include/SkSVGDefs.h"

class SkCanvas;
class SkDOM;
class SkStream;
class SkSVGNode;
class SkSVGSVG;

This works, thank you!
Although I don’t like to edit dependencies.

Also, I wouldn’t say I like it. But since we are using (for good reasons) a specific Skia branch, I see no other way to fix it yet.