Build issues on Xcode 15 - Python2 vs. Python3? - SOLVED

I am trying to migrate all of my iPlug2 projects from an older x86 Mac running Xcode 12 on Big Sur to a new M1 Mac running Xcode 15 on OS Sonoma and I am getting the same Python problem I first experienced back here P where the build fails at “” with exit code zero.

AFAIK, this is a Python error and after trying everything I did in the old thread it still does not build.

OS Sonoma uses Python3 and does not recognize Python2 commands - which seems odd but I suspect is the problem. I have searched through the iPlug2 files and Xcode settings but I don’t see where “Python” should be changed to “Python3” - if that is in fact the solution. Otherwise, why won’t it build and how to fix it?

Any direction appreciated!

OK, solved this! The new example projects in the iPlug2 bundle have indeed been updated for Python 3. The headers in the “prepare_resources” scripts now call python3 (#!/usr/bin/python3) plus I see there are several code changes for printing and reading the plist files, etc.

So, when moving older iPlug2 projects to newer iPlug2 replace the resource scripts with the new resource scripts. Bingo! It compiles and runs.

1 Like