iPlug2 Forum

macOS: Can't make a build for any IPlug example

Hi there!
I’ve programmed with IPlug2 about a year on Windows but now I need to do it on Mac. I’ve got a MacBook Pro and made all things described here. I’ve updated the macOS to 11.6, installed latest Xcode, Git for macOS, Pyton and IPlug2 (with sdk and libs). Then I opened some examples (IPlugInstrument, IPlugControls, IPlugDrumSynth), choosed macOS-APP in Scheme, pressed Run and always got an error:
error: destination '/Users/jammy/Applications/IPlugInstrument.app/Contents/Resources/IPlugInstrument.app' is inside source '/Users/jammy/Applications/IPlugInstrument.app' (not copied) (in target 'APP' from project 'IPlugInstrument-macOS')
I’ve tried few time to reinstall IPlug2 and once got a complete build for IPlugInstrument but then got such error when tried to build IPlugControls and IPlugDrumSynth. When I tried to make build for IPlugInstrument next time I got an error.
I am novice with Mac and ask for any help or suggestion where I have to look for this problem solution. Thanks!

Looking at the error message it sounds like you may have modified the xcode projects accidentally.

If you cloned the repo using git, you can reset it on the command like like this

git reset --hard HEAD

1 Like

Thank you for the answer!
Unfortunately I still can’t make a build (please find error messages and commands I have input in a terminal on the screenshot).
Do you have some other ideas?

It seems I’ve found the trouble source: I’ve checked the checkbox APP in the Target Membership but I didn’t have to do it.
Thank you very much for your help and the spent time!

1 Like