iPlug2 Forum

iPlugControls example not working on Win10

I built the iPlugEffect and iPlugSideChain examples and they work well in Windows 10.

iPlugControls does not work. It compiles without error but is not recognized by any of my DAWs.

I have the latest iPlug2 bundle, latest SDKs, etc, compiling in VS2019.

Known issue? Cause/Fix?

For me, one of the things that fixed a similar issue I had was to set the build to x86 (Build → Configurations). This makes the vst 64 bit.

I’m building as 64 bit. I built iPlugEffect and iPlugSideChain as 64 bit also. Those two work, iPlugControls does not. Not recognized by any of my DAWs. When rescanning VSTs in Reaper it crashes the scan.

Does it work for you?

I’ve had the same issue, but I haven’t looked into it in depth since I got the VST3 for my own project to build fine. However, I would hazard a guess that this could have to do with the fact that the post-build script bundles the 32- and 64-bit VST3 binaries together (so the final .vst3 “file” is actually a directory which contains the actual .vst3 binaries). It could be that Reaper fails to recognize the VST if one of the builds is missing. So perhaps try compiling both the 32- and 64-bit versions, and if that still doesn’t work, try replacing the .vst3 bundle (the one with the Steinberg icon) in your Common Files folder with the .vst3 binary in your build folder.

1 - Does the app version work?

2 - what DAWs are you using - this might be to do with the IO config for this specific plugin - if you change it to 2-2 (stereo only) does it work?

Nevermind - I found the “problem”. :flushed:

iPlugControls is an instrument plugin. I was looking for it under effects plugins.

I spotted this when I saw #define PLUG_CHANNEL_IO “0-2” in the config.h file when you asked if “2-2” worked. (I don’t write VSTis so it never occurred to me to check instrument folders in the DAWs.)

It works, both App and plugins. My apologies. Very cool demonstration, BTW. Nice new controls!

No problem - some DAWs don’t like the 0 inputs status, but yes, it’s an instrument…

Have you tried debugging the plugin? I advise you to set the breakpoint in the first line of the constructor IPlugControls. Probably also worth trying to update Visual Studio 19 to the last build.

Please see my post two threads up. It works I was just looking for it in the wrong place.