iPlug2 Forum

Problems with VST3 build

I’m having trouble building the VST3 versions of IPlug2 projects and launching them with Reaper. First, if the .vst3 file is already present in the “C:\Program Files\Common Files\VST3” folder, the VST3 bundling script fails due to an inability to access the filepath. If I delete the preexisting VST3 build, the release version will compile and launch Reaper, but not the debug version.

When I initially got the release version to compile without error, though, the plugin was still not recognized by Reaper. Working in my own project, I rebuilt the project and changed who-knows-what, which somehow got Reaper to recognize it and load the plugin. However, when I tried to generate the IPlugInstrument example (I wanted to compare the CPU usage), Reaper still can’t find the plugin, despite the .vst3 file being generated in the same place as the one for my own project (the VST3 plugin folder in Program Files).

Have you got write access to the folder?

Yeah, I set User access to “Full Control”, per the instructions on the Wiki. It seems that the access to the file itself (IPlugInstrument.vst3, etc.) is what’s restricted, as when the file doesn’t exist, a new version is successfully generated (at least for release builds). So it appears that either the file is being generated with permissions that don’t allow Visual Studio to overwrite it, or some other program is using it when I try to recompile (but I can’t imagine why that would be the case, since Reaper was definitely not running).

Also, I noticed that compiling the debug version does generate a .vst3 file, but VS can’t find or open it afterwards and run Reaper.

On this issue, I just have a clarifying question as a newbie: the .vst3 project only needs to build, not run correct? Because on build, I can find the .vst3 file, though it isn’t recognized in my ableton plugins. Is there something else that needs to be done to create a .dll file for ableton access?

Welcome @willied

iPlug2 Visual Studio and Xcode projects are setup to build and run in a DAW, when you click the “play” button in the IDE.

Sounds like you are on windows.

The project should build the .vst3 binary in a folder like this

C:\Program Files\Common Files\VST3\IPlugEffect.vst3\Contents\x86_64-win\IPlugEffect.vst3

Now when you launch Live (x64), you should see IPlugEffect in the VST3 menu. You may need to enable VST3 plugins in prefs.

If you want to click build from Visual Studio and launch/debug in Live, follow the instructions here regarding select_host.py