iPlug2 Forum

"Bundle Identifier" not matching config.h

I noticed today that the “Bundle Identifier” shown in the “Signing & Capabilities” settings for each build target does not get automatically updated to match the “BUNDLE_MFG” in config.h.

I assumed this field should automatically update but even after running build it shows “AcmeInc”.

I have manually edited each for now - and build plists are correct and plugins work - but something seems disconnected here. Shouldn’t this field automatically update to match config.h?

It’s been my experience that the bundle identifier is the same, but the update to enforce a match usually occurs on build.

If you’re using the duplicate.py script to copy an example, you’ll find a script prepare_resources-mac.py, this seems to execute on build from XCode AFAIK. I’ve explicitly noticed this when changing the bundle name manually without updating config.h, but not tried it with BUNDLE_MFR, but it stands to reason it should be the same since both are accounted for in the resource script.

Have you tried a quick build to see if it changes? If not, what happens when you manually run the python script?

P.S.

Is that a typo in the post: “BUNDLE_MFG”? in the Examples and the script it’s “BUNDLE_MFR”.
If it is the *MFG variant in your config, try renaming to *MFR and see if that works.

@meizikyn - that’s all correct - this should happen through the python script and you shouldn’t need to update them manually (which is harder to maintain).

I think (due to build ordering on Xcode) it takes two builds to fully update, but this issue is tracked here: