iPlug2 Forum

AU in Reaper not displaying "onText/offText" of BOOL parameters

Odd discovery - AU plug version running in Reaper is not displaying the assigned “onText/offText” for BOOL parameters. Control status appears in Reaper as “On/Off”.

VST and VST3 versions do show the assigned text labels and AU shows correctly in Logic Pro.

So, why is this only happening in Reaper and only with AU plugin version? Anyone else come across this?

This is likey to be to do with how different DAWs implement parameter types. If you want to be certain to get the text you want it might be better to use an enum with two items.

There are many examples of this kind of thing in plug-in development…

In iPlug1 I found it more reliable to use Int controls with 2 states rather than Bool controls. I labeled them like this and it works in all versions:

GetParam(kProcessControl)->InitInt("Duck", Process, 0, 1);
GetParam(kProcessControl)->SetDisplayText(0, "Bypassed");
GetParam(kProcessControl)->SetDisplayText(1, "Ducking");

It’s odd that this same approach is “hit and miss” in iPlug2. The above works in VST2 and VST3 but not in AAX. Conversely,

GetParam(kProcessControl)->InitBool("Duck", Process, "", 0, "", "Bypassed", "Ducking");

works in Pro Tools but not in Reaper.

Both approaches are ultimately calling GetParam(kProcessControl)->SetDisplayText() so why does one work and the other not?

Will give the enum control type a try.

Yep - just tried it and sure enough it works on both Pro Tools and Reaper (where it only worked on one or the other with my previous approach). Seems to be applying the same functions so I still don’t understand why one way works but not the other.

Anyhow, thank you!